Proteger tu contenido web

Aquí tenéis un código JavaScript para que no puedan utilizar el botón derecho del ratón y descargarse contenidos de tu blog o página web.

No es que sea la panacea, pero seguramente a alguno le eche para atrás.

Se instala como si de un gadget se tratara en blogger, eligiendo Diseño/Añadir un Gadget/(HTML/JAVASCRIPT) y en wordpress eligiendo Apariencia-Widgets-Texto, siempre que tu página la tengas con wordpress.org, con wordpress.com no funciona, no dejan hacer modificaciones de inserción de código Javascript entre otras cosas.

Donde pone AQUÍ TU MENSAJE , escribe lo que quieras que aparezca cuando accedan con el botón derecho a tu contenido. 

Aquí se puede ver lo que he puesto.

Código seguridad web

Aquí está el código, lo puedes seleccionar y copiar con Ctrl + C  o  Command + C (en Mac) , no utilices el botón derecho del ratón porque ya sabes lo que saldrá 😉   :

<script language=”JavaScript”>
<!–

function inhabilitar(){
alert (“AQUÍ TU MENSAJE“)

return false
}

document.oncontextmenu=inhabilitar

// –>
</script>

Si tienes alguna duda de su funcionamiento o instalación, escríbeme un comentario e intentaré ayudarte. Y si te ha gustado, no dudes en compartirlo.

Este script lo encontré leyendo esta entrada http://webosfritos.es/2012/09/manifiesto-contra-los-que-roban-fotos/  y en uno de los comentarios ,  Amparo de http://www.cocinandoencasa.net/ nos proporcionaba esta otra entrada http://complicacioneslasjustas.blogspot.com.es/2012/06/mensaje-de-alerta-al-intentar-copiar.html donde nos enseñaban el script.

Share and Enjoy

  • Facebook
  • Twitter
  • Google Plus
  • Pinterest
  • LinkedIn
  • Add to favorites
  • Email
  • RSS

7 pensamientos en “Proteger tu contenido web

    1. angelpero Autor

      Hola David, yo lo he puesto desde (Apariencia/Widgets) y dentro de estos he elegido (Texto) y lo he movido al Footer sin ponerle ni siquiera título ni nada , simplemente copiando el script y pegandolo en el espacio que te deja para poner cualquier texto, y así me ha funcionado.

      Responder
      1. angelpero Autor

        También puedes copiar el código y en el editor de la plantilla, en (Apariencia/Editor), eliges footer.php y lo editas y antes de pegas el código, lo guardas y ya está.
        Lo malo que si lo tengo puesto, no puedes ni siquiera copiar el código jajaj , pero bueno es pequeño o sino en el último enlace que puse en el post lo puedes copiar también.
        Si no te lo envio por mail, tu me dirás, aunque imagino que ya lo copiaste de ese enlace o lo transcribiste, si es así, mira bien no te equivocaras al escribirlo.

        Responder
        1. David Esteban

          He probado todo, y nada! jeje. Sí, he seleccionado el texto desde tu blog, “Ctrl+C”, ese comando sí funciona.

          A mí en “Apariencia” no me aparece nada de “editor”, vaya tela. Pero bueno, no te preocupes Ángel, me da que es cosa del tema que tengo elegido como plantilla.

          Muchas gracias!

          Responder
          1. angelpero Autor

            De todas maneras, puede deberse a que usas alojamiento gratuito en wordpress.com con lo que si quieres hacer modificaciones o personalizar el blog de diferente manera, te encontraras con que no te deja hacer ciertos cambios, por eso no te sale el “Editor” y a mi sí, porque en mi caso tengo un alojamiento de pago y entonces tengo instalado todo el paquete de codigo abierto de WordPress.org, con lo que me deja hacer cualquier cosa.

            Pero también tengo otro blog en blogger, gratuito y no me ha dado problema el instalarlo allí.

            Por lo que he leido, por motivos de seguridad, no se admite código javascript en wordpress.com 🙁

            Editaré la entrada para hacer esa observación.

  1. David Esteban

    Sí, yo creo que debe ser eso, con cuenta gratuita no deja modificar código. En tumblr sí se puede a pesar de ser gratuito, estoy seguro. Es una pena, pero bueno, gracias por molestarte en ayudar.

    Un saludo Ángel!

    Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *